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1. Introduction to Kernel for SQL 

Welcome to the user manual for Kernel for SQL, an effective and powerful data recovery software to 
recover data from the corrupt SQL databases (.mdf). This user manual comprises step by step guidelines 
on using Kernel for SQL. 

1.1  Using this Manual 

This user manual is intended to guide users on using Kernel for SQL. We suggest that first time users 
should read this user manual completely and carefully before proceeding to use the software. However, if 
you are an experienced user, you can use the table of contents to find out information pertaining to the 
tasks that you need to perform by using Kernel for SQL. 

You can use the table of contents to navigate through different sections of this user manual. The table of 
contents lists all the sections that are contained in this user manual in chronological order. This user 
manual comprises following sections: 

 Introduction 

 Getting Started 

 Software Interface 

 Repairing .MDF Files 

 Full Version 

 Support 

 Troubleshooting 

 Legal Notices 

Certain abbreviations have been used throughout this manual. For clear understanding of the contents of 
this user manual, please go through the list of abbreviations, mentioned below, before reading the manual. 

1.1.1 List of Abbreviations 

MS: Microsoft 

SQL: Structured Query Language 

QFSCI: Quick File System Component Identification 

RAM: Random Access Memory 

MB: Mega-Byte 

GB: Giga-Byte 
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1.2 About Kernel for SQL 

Kernel for SQL is database recovery software that recovers data from corrupt, damaged .mdf database 
files. Kernel for SQL software is equipped with powerful QFSCI algorithm which efficiently scans and 
retrieves data from the corrupt databases. 

The common reasons which lead to SQL database corruptions are: 

 Invalid database file header 

 Not able to associate database file with different databases 

 Internal Program Error(s) 

 Crash or failure of hard drive 

 Media contamination or damage 

 Accidental deletion of data and files 

 Accidental reformatting of partitions 

 Virus attacks 

 Data corruptions 

1.3 Salient Features 

Salient features of Kernel for SQL include: 

 Supports recovery of data from MS SQL Server version 2000 and 2005 

 Effectively repairs and extracts data from the corrupt SQL database (.mdf) 

 Creates script file(s) where the recovered files are saved 

 Deleted records can be recovered and are saved in a separate SQL script 

 Recovery of Microsoft SQL server backup files 

 Recovery of tables, triggers, views, and stored procedures 

 Recovery of primary keys, indexes, unique keys and foreign keys 

 Recovery of predefined defaults, default values, rules, checks, and user data types (default, rule, Allow 
null) 

 Efficiently repairs large databases 

1.4 Who Should Use this Software? 
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The capability of Kernel for SQL to repair large SQL databases makes it appropriate for use by SQL 
server administrators, who need to recover data from corrupt or damaged .mdf database files. The 
corruption could have been caused due to virus attacks, improper system shutdown, network problems, 
database file header corruption etc. 
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2. Getting Started 

Now that you have understood the features and potential of Kernel for SQL, you are ready to get a hand 
on experience of the software. To start repairing .mdf files, you will first need to download and install this 
software. 

It is strongly recommended that before installing Kernel for SQL, you should go through the installation 
pre-requisites for the software to ensure that your computer is appropriately configured to run the 
software. 

2.1 Installation Pre-requisites 

The various pre-requisites for installing and running Kernel for SQL can be broadly classified into two 
major categories – Hardware requirements and Software requirements. 

2.1.1 Hardware Requirements: 

The hardware requirements for installing the software are as follows: 

 Pentium Class processor 

 Minimum 64MB RAM (128 MB recommended) 

 10MB for Software installation 

 Disk Space - Enough space to store the repaired files 

@ You should have at-least 40 MB of free disk space if you want to repair and save a 
40 MB.mdf file. 

2.1.2 Software Requirements: 

The software requirements for installing the software can further be grouped into two categories– 
Operating system requirements and SQL Server version requirements. The requirements are as follows: 

2.1.2.1 Operating System Requirements 

Supported operating systems: 

 Windows Vista 

 Windows XP 

 Windows 2003 

 Windows 2000 
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2.1.2.2 SQL Server Version Requirements 

Supported MS SQL Server versions: 

 SQL Server 2000 

 SQL Server 2005 

2.2 Downloading Kernel for SQL for the First Time 

After checking your computer with the prescribed system requirements for Kernel for SQL, you can 
download and install the software on your computer. You can buy the full version of the software from any 
one of our authorized resellers– Element5, Asknet and 2CO. 

If you want to try using Kernel for SQL before buying it, you can download the evaluation version from the 
following link: 

http://www.nucleustechnologies.com/download-sql-recovery.php 

@ You can repair .MDF files saved on your system by using the evaluation version of 
Kernel for SQL; however, the repaired file will not be saved until you purchase the 
full version of the software. 

2.3 Install Kernel for SQL 

After downloading the installer file for Kernel for SQL, you can install the software by running the file. To 
install Kernel for SQ: 

1. Double-click the Kernel for SQL installer. Follow the on-screen instructions. The Setup Installation 
Complete screen will be displayed. 

2. Click Finish to launch the software. 

2.4 Start Kernel for SQL 

To start Kernel for SQL: 

Click the Start Ą All Programs ĄKernel for SQL 

Alternatively, you can launch Kernel for SQL by double-clicking the shortcut icon available on the Desktop 
and Quick Launch icon. 

2.5 Uninstall Kernel for SQL 

You may need to uninstall and re-install Kernel for SQL. To uninstall Kernel for SQL: 

1. Click the Start Ą All Programs ĄKernel for SQL Ą Uninstall Kernel for SQL 

A warning message will be displayed. 

http://www.nucleustechnologies.com/download-sql-recovery.php
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2. Click ‘Yes’ to uninstall Kernel for SQL. 

@ Before proceeding to uninstall Kernel for SQL, you must ensure that the software is 
not running. 

You can alternatively uninstall Kernel for SQL from the Control Panel by performing the following steps: 

1. Click the Start Menu Ą Control Panel and then double click the Add or Remove Programs icon. 

2.  Select Kernel for SQL and click Remove. A warning message will be displayed. 

3. Click Yes to uninstall Kernel for SQL. 
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3. Software Interface 

Now that Kernel for SQL has been installed on your computer, you can start using the software after 
getting acquainted with the software interface. 

3.1 Menu-bar 

The menu-bar of Kernel for SQL comprises four main menus – File, Tools, View, and Help. 

3.1.1 File Menu 

The File menu comprises five menu items. 

 

Figure 3.1: File Menu 

Menu items in the File menu: 

Field Name Field Description 

Select Select to browse and list corrupt .MDF file from your disk 

Recover Select to start the repairing process of the listed corrupt .MDF file 

Save Select to save the recovered results from .MDF file 

Live Update Select to update Kernel for SQL (updated/modified) version from 
the Nucleus Data Recovery server 

Exit Select to close the software 

3.1.2 Tools Menu 

The Tools menu comprises one menu item. 
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Figure 3.2: Tools Menu 

Menu Items in the Tools menu: 

Field Name Field Description 

Option Select to define the recovered file saving 
location 

3.1.3 View Menu 

The View menu comprises four menu items. 

  

Figure 3.3: View Menu 

Menu items in the View menu: 

Field Name Field Description 

Toolbars Select to activate or deactivate the Standard bar and to 
customize software 

Status Bar Select to activate or deactivate Status bar in software 

Table Name Window Select to view or hide the Table Name Window in the 
software 

Table Summary Window Select to view or hide the Table Summary Window in 
the software 
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3.1.4 Help Menu 

The Help menu comprises three menu items. 

 

Figure 3.4: Help Menu 

Menu items in the Help menu: 

Field Name Field Description 

Help Select to view user's help guide of Kernel for SQL 

Buy Online Select to purchase software online from the website 

About Kernel for SQL Select to view version information of the software 

3.2 Tool-bar 

The tool-bar in Kernel for SQL is displayed below the menu-bar. The tool-bar provides a convenient and 
user-friendly method to perform certain actions that can also be performed by using the menu-bar. Read 
the information in the table below to find out about the tool-bar buttons: 

Button Button Name Button Description 

 

Select Click to select corrupt .MDF file from your disk 

 

Recover Click to start the recovery process of the corrupt 
.MDF file 

 

Save Click to save the recovered results on your disk 



© N u c l e u s  D a t a  R e c o v e r y . C o m  P r i v a t e  L i m i t e d   

 

Option Click to define saving location of the recovered 
results 

 

Update Click to update old version of the software with the 
new updated version of the software 

 

Buy Online Click to purchase the software online from the 
Nucleus Data Recovery website 

 

Help Click to view User's guide of Kernel for SQL 

3.3 Status Bar 

Status bar is displayed at the bottom of the software window. The text ‘Ready’ is displayed on the status 
bar if Kernel for SQL is ready to be used. Status bar also displays the text ‘CAP’, ‘NUM’, ‘SCRL’ which 
respectively correspond to the Caps Lock, Num Lock, and Scroll Lock keys on your keyboard. If any of 
these keys are pressed, the color of the corresponding text will turn blue/black. 

 

Figure 3.5: Status Bar 

3.4 Buttons Used 

Apart from the standard options available in the menu-bar and the tool-bar, following are the buttons which 
are displayed on the main window. 

 

Click to browse and select the .mdf file that needs to be repaired 

 

Click to start with the recovering process 

 

Click to go back to main window of software 
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Click for saving the recovered files 

 

Click to stop the repairing process 

 

Click to open the recovered file for viewing 

3.5 Customize User Interface 

You can add or remove toolbar buttons by clicking: 

 Button in the toolbar and selecting appropriate buttons. 
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4. Repairing .MDF Files 

Now that you have complete familiarity of the user interface of Kernel for SQL, you are ready to repair .mdf 
files. 

To repair .mdf files: 

1. Launch Kernel for SQL. 

 

Figure 4.1: Main Window 

2. Select the appropriate option: SQL 2000 or SQL 2005 to recover data from the respective .MDF file. 

@ Kernel for SQL allows you to recover data from SQL database 2000 and SQL 
database 2005 file separately. 

3. Click the Select file button to select the corrupt .MDF file from your disk. 
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Figure 4.2: Select File to Recover  

4. Select the corrupt file and click the Open button. 

5. Click the Recover button to start the recovery process. 

 

Figure 4.3: Selected File 
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After repairing the corrupt .mdf file, Kernel for SQL will display the recovered results in table like view. 

6.  Select the table to view its content. 

 

Figure 4.4: Recovered Tables 

@ Software displays summary of the recovered results on Left side of window under 
the Summary heading. The number of tables in the corrupt .mdf file is displayed 
under the Tables heading. 

7. Click the Go to Save button to save the recovered results. 

@ You cannot save the recovered results in Evaluation version of Kernel Recovery for 
SQL. Full version needs to be purchased for saving purpose. 

8. Software asks for the saving location which can be defined using the Browse button. 
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Figure 4.5: Defining Saving Location 

@ By default Kernel for SQL saves the recovered results at C:\Program Files\Kernel for 
SQL Database Recovered\ 

9. Click the Save button to start the process of saving. After saving process gets completed, Kernel 
Recovery for SQL will display the save file location link of the recovered file. 

10. Click the link to view the saved recovered files or Click the Open button to view the recovered results. 
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5. Full Version 

Although you can use Kernel for SQL evaluation version for free and experience the capabilities of the 
software, there are certain features that are not available in the evaluation version. 

5.1 Requirement of Full Version 

By using the evaluation version of Kernel for SQL, you can repair corrupt .mdf files; however, you cannot 
save the recovered data. 

You will need to buy the full version of the software to save the recovered .MDF files. 

5.2 Purchasing Full Version 

You can buy the full version of Kernel for SQL from any one of our authorized resellers – Element5, 
Asknet and 2CO. 

As soon the purchase transaction with our resellers gets completed, our sales team will send you an email 
comprising the URL to download the full version of Kernel for SQL and activation details of the software. 
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6. Support 

We have an extensive and efficient support system in place to assist our customers with all issues related 
to using Kernel for SQL. The software comes with an embedded help manual that can be accessed by 
clicking HelpĄ Help in the menu-bar. You can also press the F1 key on the keyboard of your computer to 
access the embedded help of Kernel for SQL. 

You can access the online help for Kernel for SQL at http://www.nucleustechnologies.com/Online-
Helps.html 

View Animated Product demo of the software at 
http://www.nucleustechnologies.com/Animated_Demo_SQL_Recovery.html 

We also have live support wherein you can chat with our software experts at 
http://www.nucleustechnologies.com/Support.html 

To talk on phone with our software experts call: 

Help line:  
 

+91-9818725861 

1-866-348-7872 (Toll Free for USA/CANADA) 

You can also email us about your queries at; 

sales@nucleustechnologies.com for Sales 

support@nucleustechnologies.com for Support 

contact@nucleustechnologies.com for General Queries 

  

http://www.nucleustechnologies.com/Online-Helps.html
http://www.nucleustechnologies.com/Online-Helps.html
http://www.nucleustechnologies.com/Animated_Demo_SQL_Recovery.html
http://www.nucleustechnologies.com/Support.html
mailto:sales@nucleustechnologies.com
mailto:support@nucleustechnologies.com
mailto:contact@nucleustechnologies.com
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7. Troubleshooting 

This section deals with your generic and specific queries pertaining to using Kernel for SQL 

7.1 Common Issues 

Why does Kernel for SQL have limitations in evaluation copy? 

The free evaluation version of Kernel for SQL is intended to enable you to experience the capabilities of 
the software. You will need to buy the software to save the recovered results. 

7.2 Frequently Asked Questions 

How to Buy Kernel for SQL? 

You can buy Kernel for SQL online at http://www.nucleustechnologies.com/buy-sql-recovery.php  

I have lost my full version for Kernel for SQL. Can you help me? 

Please email us at sales@nucleustechnologies.com. Please include your name, address, email address, 
and order confirmation number (if you have it). We will be happy to help you. 

  

http://www.nucleustechnologies.com/buy-sql-recovery.php
mailto:sales@nucleustechnologies.com
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8. Legal Notices 

This section comprises the legal specification about Kernel for SQL and the company NUCLEUS DATA 
RECOVERY.COM PRIVATE LIMITED 

8.1 Copyright 

NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED, Nucleus Kernel accompanied user manual and 
documentation are copyright of NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED, with all rights 
reserved. Under the copyright laws, this user manual cannot be reproduced in any form without the prior 
written permission of NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED. No Patent Liability is 
assumed, however, with respect to the use of the information contained herein. 

© NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED. All rights reserved. 

8.2 Trademark 

Kernel TM is a copyright work of NUCLEUS DATA RECOVERY.COM. 

Windows 95®, Windows 98®, Windows ME®, Windows NT®, Windows 2000 Server®, Windows 2000 
Advanced Server®, Windows 2003 Server®, Windows XP®, MS SQL Server and MS-DOS are registered 
trademarks of Microsoft Corporation. 

All other brand and product names are trademarks or registered trademarks of their respective companies. 

8.3 Disclaimer 

The Information contained in this manual, including but not limited to any product specifications, is subject 
to change without notice. NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED provides no warranty 
with regard to this manual or any other information contained herein and here by expressly disclaims any 
implied warranties of merchantability or fitness for any particular purpose with regard to any of the 
foregoing NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED assumes no liability for any damages 
incurred directly or indirectly from any technical or typographical errors or omissions contained herein or 
for discrepancies between the product and the manual. In no event shall NUCLEUS DATA 
RECOVERY.COM PRIVATE LIMITED, be liable for any incidental, consequential special, or exemplary 
damages, whether based on tort, contract or otherwise, arising out of or in connection with this manual or 
any other information contained herein or the use there of. 

8.4 License Agreement 

Kernel for SQL is Copyright © by NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED 

Your Agreement to this License 

You should carefully read the following terms and conditions before using, installing or distributing this 
software, unless you have a different license agreement signed by NUCLEUS DATA RECOVERY.COM 
PRIVATE LIMITED. The terms and conditions of this License describe the permitted use and users of 
each Licensed Copy of Kernel for SQL. For purposes of this License, if you have a valid license, you have 
the right to use a single Licensed Copy of Nucleus Kernel. 
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Scope of License 

Each Licensed Copy of Kernel for SQL may either be used by a single person or used non-simultaneously 
by multiple people who use the software personally installed on a single workstation. All rights of any kind 
in Nucleus Kernel, which are not expressly granted in this License, are entirely and exclusively reserved to 
and by NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED. You may not rent, lease, modify, 
translate, reverse engineer, decompile, disassemble, or create derivative works based on, Nucleus Kernel, 
nor permit anyone else to do so. You may not make access to Nucleus Kernel available to others in 
connection with a service bureau, application service provider, or similar business, nor permit anyone else 
to do so. 

Warranty Disclaimers and Liability Limitations 

Kernel for SQL, and any and all accompanying software, files, data and materials, are distributed and 
provided AS IS and with no warranties of any kind, whether expressed or implied. In particular, there is no 
warranty for the quality of data recovered. You acknowledge that good data processing procedure dictates 
that any program, including Nucleus Kernel, must be thoroughly tested with non-critical data before there 
is any reliance on it, and you hereby assume the entire risk of all use of the copies of Nucleus Kernel 
covered by this License. This disclaimer of warranty constitutes an essential part of this License. In 
addition, in no event does NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED authorize you or 
anyone else to use Kernel for SQL in applications or systems where Kernel for SQL failure to perform can 
reasonably be expected to result in a significant physical injury, or in loss of life. Any such use is entirely at 
your own risk, and you agree to hold NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED harmless 
from any and all claims or losses relating to such unauthorized use. 

General 

This License is the complete statement of the agreement between the parties on the subject matter, and 
merges and supersedes all other or prior understandings, purchase orders, agreements and 
arrangements. This License shall be governed by the laws of the State of Delhi. Exclusive jurisdiction and 
venue for all matters relating to this License shall be in courts and for a located in the State of Delhi, and 
you consent to such jurisdiction and venue. There are no third party beneficiaries of any promises, 
obligations or representations made by NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED herein. 

 Any waiver by NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED of any violation of this License by 
you shall not constitute, nor contribute to, a waiver by NUCLEUS DATA RECOVERY.COM PRIVATE 
LIMITED of any other or future violation of the same provision, or any other provision, of this License. 


